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Making the most of your BIC 



 
 

 

Creating and linking a report 

Did you know you can customise the look and layout of the Pastel BIC reports? Pastel BIC standard 

reports are designed to cater for the masses, you might want to change the look (colours, font style) to 

suit your company image, and you might want to change the layout (move columns, add or remove 

columns) to suit your company processes and save these changes for the next time you run the report. 

Before we start 

If you are unsure of making changes to any of the standard reports, it would be a good idea to make a 

copy of the report before you make any changes to the report. 

 

How to Copy a report 

Open Report Manager and right click the report you want to copy, then select the Copy option. Right click 

on the report folder you want to paste the copy to, and select the Paste option. The copy of the report will 

be renamed as ñCopy ofò followed by the original report name.  

 

 

How to Create and Link the report 

 

1. Open your Pastel BIC Report Manager 

 

2. Select and run out the report you want to customise  

 

 
 

3. Make the changes to the report; ensure that Sheet1 (where Pastel BIC puts the Raw Data) and 

Sheet2 (where Pastel BIC puts the report parameters) are unchanged.  



 
 

 

 
 

 

4. Once the changes have been made, leave the workbook open, and go back to Report Manager. 

Right click on the report for which the changes where made, and select the Create and Link 

Template option. 

 

 
 

 

5. The popup window will show a list of all open Excel workbooks, select the workbook you have 

made the changes to and click OK. 



 
 

 
6. You will be prompted with the message below, and as mentioned in point 3, you should not make 

changes to Sheet2. Click Yes to link the workbook, if you select No the workbook will not be 

linked. 

 
 

7. You will also be prompted to specify the template name. It is a good idea to change the name of 

the template to ensure that the original template is not overwritten with the customised one, and 

click OK.  

 

 
 

8. A message will be displayed once the template has been successfully linked. 

 
9. Quite easily done! 



 
 

Copy and Pasting BIC Reports 

 

Did you know you can copy and paste a report, at any stage, in the report manager?  

 

Where would this be useful? 

This can be very useful if you do not want to corrupt the master report, or you would like to create hybrids 

of an existing report.  

 

You might have a sales report that shows a customer analysis on sales, and you want to create another 

report that shows sales analysed by Reps instead. The wise thing to do is create a copy of the original 

report, and then rename the copy to Sales by Rep, and then customise the new ñSales by repò report. 

You have the benefit of re-using all the IP in the original report without having to create it from scratch. 

This is how you do it. 

1. Open your Report Manager 

 

 
 

2. Right click on the report you want to make a copy of 

Select copy from the popup list 

This has pasted the report to the clipboard ï now you need to paste the report onto a folder. 

 

3. Select the required folder ï this might be the same folder that the original report was in, or a 

different folder. 

 

Right click on the folder and choose paste from the popup menu 



 
 

 

 
 

 

Note ï you can also use the shortcut keys of Ctrl-C to copy the report, and Ctrl-V to paste it 

instead of using the menus. 

 

4. You can now rename the newly copied report ï by default the new name will be ñCopy of <old 

name>ò so it can be distinguished from the original report. 

 

 
 

5. Right click on the report and select the ñrenameò option to rename the report. 

What you have now is an exact duplicate of the original report that will get its data from the same 

place, and deliver it in the same format ï until you make any changes to this new report. 



 
 

Importing and exporting BIC reports 

Why would we want to do this? 

One of the great features in Pastel BIC is the ability to create reports and be able to share them with other 

Pastel BIC users. Another significant use is to export problematic reports and send them to be fixed, and 

then import them once they are ready ï in this day and age with significant traffic congestion, this can be 

a huge time and money saving for you. It is essentially a transport mechanism for reports that removes 

the risks of cutting and pasting various elements of a report manually. 

Exporting a Report: 

Reports can be exported from one Pastel BIC system and imported into another. The export function can 

create either a flat file (.alx extension) or a file in a compressed file format (.al_ extension). Either of these 

file type may then be distributed for import into other Pastel BIC systems.  

To export a report, simply select the report in the Report Manager Interface or from the Tools menu you 

can run ñExport Reportò.  

You will be prompted for a Metabase Version. Select the highest version, unless the installation you 

intend importing the report to is running on an older version of Pastel BIC. 

  

You will be prompted to select a location to save the export file. 

 

 

Note: Use a compressed file format (AL_ files) for space efficiency. This is useful when you need to 

distribute reports.  

 



 
 

Note that if you are running a Third Party Developer License of Pastel BIC, then it is possible for you to 

protect your export files. Below is a screenshot of the additional functionality provided. 

 

 

Export files can be imported into your Pastel BIC system from the Report Manager or the Administrator 

Tool.  

 

 

 

To import a report using the Report Manager, perform the following steps:  

¶ Open the Report Manager. 

¶ Click on "Home" in the Object window 

¶ Select the Tools menu. 

¶ Select the "Import Report" function 

¶ You will be asked to locate the Pastel BIC export file (*.ALX or *.AL_) 



 
 

¶ Browse to the file and press Open. 
 

Pastel BIC will show the following dialogue screen, which contains information for the import and requires 

you to select a Target Connection and a Report Destination. 

 

¶ Select a Target Connection from the drop down field provided 

¶ Select a Report Destination folder from the drop down field provided. 

¶ In the event that you would like to create a new folder in which to place this report then click the 
ñNewò button 

¶ Type in a name for the folder and click OK 

¶ Click on Import. 
 

Pastel BIC will try and locate a Source Container in the selected connection that matches the one used 

by the original report. You will be given the option of using this one if a match is found or creating a new 

one. Where possible it is recommended that you use existing Source Containers.  Your report should now 

be available for use in the Report Manager. 

 

 

 

 

 

 



 
 

To Import a report using the Administrator Tool, perform the following steps:   

¶ Open the Administrator tool. 
 

 
 

¶ Drill down to and select the Connection from which the report will be drawing data. 

¶ Select the Tools menu 

¶ Select the "Import Report" function. 
 

 
 

¶ You will be asked to locate the Pastel BIC export file (*.ALX or *.AL_). 

¶ Browse to the file and click Open 
Select a Report Destination folder from the drop down field provided. 

¶ In the event that you would like to create a new folder in which to place this report then click the 
ñNewò button 

¶ Type in a name for the folder and click OK 

¶ Select Import 
 

Pastel BIC will try and locate a Source Container in the selected connection that matches the one 
used by the original report. You will be given the option of using this one if a match is found or 
creating a new one. Where possible, it is recommended that you use existing Source Containers. 
 
Your report should now be available in the Report Manager. 



 
 

Automatically distribute BIC Reports on the Web or an Intranet 

Did you know that you can automatically distribute any Pastel BIC report on the web or on an intranet. It 

often happens that information rich reports, which could help your organisation, are sitting on someoneôs 

desk ï if only they could be easily distributed to the right people ï effortlessly.  

Hereôs how it is done: 

1. Open your Report Manager. 

 

2. Select the report that you want to publish to an intranet/ internet. 

 

 
 

 

3. Select the check box to Show Advanced Properties of a report ï it is at the bottom of the 

properties tab window.  

 

 
 

4. Select the button to óRun Add-insò - this will be listed in the properties window of the report. 

 
 

. 



 
 

5. Select the option to óSpecify a New Add-in Functionô and select OK. 

 

 
 

6. A box will appear as follows  

 

 
 

Select the Add-In Library, and Add-in Library Module as shown above. Select the Add in 

Function followed by the OK button. 

 

 

7. A box will pop up asking you to enter all the relevant details for distribution ï see below 

 



 
 

 
 

This will include details about the name of the sheet to be published and a fully qualified path for 

the HTML file. (with filename and extension)  

 

8. When you have entered your details, select OK and you will see that a string has been added into 

the ñAdd-Insò box in the properties window of your report. 

 

 

 
 

9. QED (Quite Easily Done!) 



 
 

 

Auto e-mailing Pastel BIC reports 

Did you know that you can automatically distribute any Pastel BIC report once it has been run, to a 

distribution list of your choice? It often happens that information rich reports, which could help your 

organisation, are sitting on someoneôs desk ï if only they could be easily distributed to the right people ï 

effortlessly.  

Hereôs how it is done: 

1. Open your Report Manager. 

 

 

2. Select the report that you want to setup for e-mailing automatically once it has been run. 

 

 
 

 

 

 

3. Select the check box to Show Advanced Properties of a report ï it is at the bottom of the 

properties tab window.  

 

 
 

 

4. Select the button to óRun Add-insò - this will be listed in the properties window of the report. 

 



 
 

 
 

. 

5. Select the option to óSpecify a New Add-in Functionô and select OK. 

 

 
6. A box will appear as follows  

 
Select the Add-In Library, and Add-in Library Module as shown above. Select the Add in 

Function followed by the OK button. 

 

 

7. A box will pop up asking you to enter all the relevant details for emailing ï see below 



 
 

 
This will include details about your mail SMTP server which you must get from your mail 

administrator, as well as the ófromô and ótoô addresses. To send to multiple e-mail addresses, use 

a colon in between addresses. Ensure that when you give the report a name that you include the 

ñ.xlsò extension as well.  Scroll down on this window to see more available options. 

 

8. When you have entered your details, select OK and you will see that a string has been added into 

the ñAdd-Insò box in the properties window of your report. 

 

9. Execute the report, and it will automatically be e-mailed to the selected recipients. 

 
10. QED (Quite Easily Done!) 



 
 

Hiding and Showing BIC Reports 

 
Why would you like to show or hide reports? 
It is handy to be able to hide reports that do not need to be run separately, but only as union reports. This 
will give your object window a neater look. 
 
To hide a report: 
1. Select the report in the Object window of the Report Manager, under Properties select 
2. Show Advanced 
3. Under the properties tab, select the option Report Hidden 
4. Refresh your object window view by double clicking on Home at the top of the screen 
5. Now the report will not show in your list of available reports 
 

 
 
To show a hidden report 
1. Select the Home object in Report Manager 
2. Select Show Hidden Reports 
 

 
 
Refresh you object window by double clicking on Home at the top of the screen. You will now be able to 
view your hidden reports 
Please take note that access to make changes to a report will not be available on the reports which make 
up a union report. These reports have a black arrow next to them in the object window. Access is 
available to the reports with blue lines next to them. 



 
 

Scheduling Pastel BIC Reports 

Pastel BIC reports can be run unattended, from Operating System batch files or under the control of 
external scheduling software (such as the Microsoft Windows Scheduler or the Microsoft SQL Server 
Agent). This can be useful when you have certain reports that you need to run on a regular basis.  

When reports are run unattended they are automatically closed on completion. Scheduled reports 
must use the Generate Output Advanced report or the Retain Run Instances option to be useful. See 
Advance Report Properties for more information.  

Typically reports that are scheduled will have the Generate Output File property set so that the 
unattended reports are saved to a specific location. Set this property under the Advanced options on 
the Report Properties tab. 

 To generate the command to schedule a report run: 

1. Open the Report Manager 
2. Select the report you wish to generate a schedule command for 

3. Click on the Schedule Icon  .  
4. If the report expects parameters then you will be prompted to enter these. Enter any necessary 

parameters and click OK. 
5. A message box will then appear that will display the syntax for the running the report. Additionally 

this text will be placed on the windows clipboard so that it can be pasted into the application or 
batch file that will be controlling it. An example is shown below. 

 

When reports are run unattended the information that is usually sent to the Process Monitor window is 
redirected to a log file. You should review this log file to make sure that your reports are running as 
expected. The log file is named Alchemex Pastel BIC Unattended.log and can be found in the Logs folder 
which is a sub folder of the Pastel BIC Installation folder. 

You can view this log file in a text editor application such as Notepad.  

The file can also be opened directly from the Administrator Tool. To do this Open the Administrator Tool 
and choose the Menu item Tools > Open Log File. 

The application returns a process exit code for the scheduled report to indicate Success (0) or Failure (1) 
allowing the calling process to check the result of a shelled report. 

 

 

 

 



 
 

Scheduling a Report using the Windows Scheduler  

1. Select the report that you wish to schedule in the Report Manager. 

2. Click on the Schedule Icon on the toolbar or right click on the report and choose Generate 
Scheduler Command. 

3. If the report expects parameters then you will be prompted to enter these. 
4. A message box will then appear that will display the syntax for running the report. 
5. Additionally this text will be placed on the windows clipboard so that it can be pasted into the 

scheduled task command field.  

Reports that are Scheduled are closed on completion and therefore must use the Generate Output 
Advanced report or the Retain Run Instances option to be useful. See Advance Report Properties for 
more information. 

Open the Windows Control panel and then open the Scheduled Tasks item. 

1. From the menu choose File > New > Scheduled Task. 
2. A new Scheduled Task will appear in the explorer window. 
3. Rename the task with a meaningful name. 
4. Select the new task 
5. From the menu, choose File > Properties.  
6. Place the cursor in the Run text box, right click and choose Paste. 
7. The run command for the report will be copied from the clipboard into the Run box. 
8. You can optionally enter a comment describing the scheduled report. 
9. Leave the Start In box blank. 

 

  

In the Run As box enter the user name that should be used to run the report under (for domain user 
accounts use the format domain_name\user_name) . The user name must be a valid account on the 


